发 帖  
原厂入驻New
[问答] harmony 1.04.01演示应用程序不工作怎么办
28 Harmony
分享
我有一个PIC32MX以太网启动器套件,我试图使用HARMony v1.04.01套件中的snmp_nvm_mpfs演示应用程序。除了陷阱演示之外,大多数演示应用程序都是工作的。我使用的是iReasoning浏览器,我能找到的唯一指令是在旧的MLA tcp/ip pdf文件中,该文件应该仍然适用?我能够正确地设置trapEnabLED、trapReceiverIPAddress和trapCommunity字段,并且当我进行散步时,我看到取值了。我运行了wireshark,还尝试打开iReasoning陷阱查看器应用程序,但是没有收到任何东西。我在._snmp_app.c文件中的SNMPv2TrapDemo()函数中放置了一个断点,并且我看到应用程序正在命中看起来应该发送陷阱的函数,但是我需要理解这稍微好一点。有人测试过陷阱演示并成功运行了吗?
0
2020-5-14 10:16:54   评论 分享淘帖 邀请回答
2个回答
不幸的是,这是一个发布的产品使用1.04.01堆栈,但最终我打算去1.06。我已经修改了这个产品上的TCP/IP协议栈,因为我们接收到特殊的以太网帧。我看了一下1.06的堆栈,它完全不同了,我必须弄清楚如何合并我对那个版本的更改。我有一个想法,SNMP陷阱在演示中工作,我只是没有做正确的事情,或者至少我希望是这样的。
2020-5-14 10:36:05 评论

举报

你可以试试V1.06陷阱DEMO。V1.06不会打扰V1.04。但是,确保你没有更新MHC。V1.04并不总是正确地使用更新的MHC。是的,更新可能是一种痛苦。
2020-5-14 10:44:35 评论

举报

只有小组成员才能发言,加入小组>>

108个成员聚集在这个小组

加入小组

创建小组步骤

关闭

站长推荐 上一条 /7 下一条

快速回复 返回顶部 返回列表