发 帖  
原厂入驻New
[问答] 如何安装和升级了AWS CLI
188 AWS iot
分享
我在下面的项目WCM AWS IOT-SDK AthTPS://GITHUBCOM/MICHCHIPtiC/WCM-AWS IOT-SDK。基于和声版本1-06的代码,我根据指令成功地安装和升级了AWS CLI。在CMD提示和GT;AWS配置中键入之后,我按要求输入了访问密钥ID和访问密钥。在README.md指令之后,它要求在终端窗口中运行以下命令。>aws iot.-endpointI收到错误响应“调用DescribeEndpointoperation时发生错误(SubscriptionRequiredException):AWS访问密钥Id需要订阅服务器“我错过了订阅的东西,但是Read的指令。MD从不要求订阅服务。
0
2020-4-29 07:57:55   评论 分享淘帖 邀请回答
1个回答
好的,我想我已经通过了上面的回复。但是现在我又被下一个指令卡住了。在Cmd提示符中,我执行了>aws iot创建策略--policy-name PubSubToAnyTopic--policy-document文件://C:wcm-aws-iot-sdk-masterfileand有响应,即{policyName":"PubSubToAnyTopic","policyArn":"arn:aws:iot:us-.-2:56296374214"。2:policy/PubSubToAnyTopic", "policyDocument": "{\n \"Version\": \"2012-10-17\",\n \"Statement\": [{\n\t\"Effect\": \"Allow\",\n\t\"Action\":[\"iot:*\"],\n\t\"Resource\": [\"*\"]\n }]\n}", "policyVersionId": "1"}but when i come to>aws iot attach-principal-policy --principal-arn certificate-arn --策略名称PubSubToAnyTopic从CLI得到的错误是,用法:aws[.]<command><subcommand>[<subcommand>...][.]要查看帮助文本,可以运行:aws help aws<command>help aws<command>subcommand>help aws:error:.--prin.l是必需的dI已经正确地按照所提供的自述文件中的所有指令执行了,但我怀疑上面的相关命令必须有更新。我喜欢使用这个代码作为参考,因为代码复杂度低于使用PIC32 MZ的后面的代码。期待微微芯片专家对微芯片技术开发的IOT SDK应用/解决方案的帮助和建议。
2020-4-29 08:04:58 评论

举报

只有小组成员才能发言,加入小组>>

113个成员聚集在这个小组

加入小组

创建小组步骤

关闭

站长推荐 上一条 /7 下一条

快速回复 返回顶部 返回列表