发 帖  
原厂入驻New
[问答] 请问CC2540主机与iOS从机蓝牙为什么断开?
2020-3-20 08:53:29  228 iOS CC2540 蓝牙
分享
你好,我在使用CC2540与iOS设备进行蓝牙通信,CC2540作为主机,而iOS端则作为从机。现在我再编写iOS端作为从机内容的时候,和CC2540通信后,使用串口调试显示结果是:
BLE Central
Devices Found1
<- to select
connecting
connected
simple svc found
disconnected
reason:19
我想询问突然断开的具体原因是什么?封装后查看不了这块的代码。找了蛮久也不知道reason:19是什么意思。希望能够得到解答。谢谢。
0
2020-3-20 08:53:29   评论 分享淘帖

相关讨论

8 个讨论
你好,我想问问有没有关于CC2540做主机,而iOS做从机的peripheral这份demo??可以提供给我吗?
2020-3-20 09:29:17 评论

举报

上海鼎廷 发表于 2020-3-20 13:37
你好,我想问问有没有关于CC2540做主机,而iOS做从机的peripheral这份demo??可以提供给我吗?

没有 但是我想可以用SimpleBLEPripheral和lightblue来调
2020-3-20 09:48:26 评论

举报

合肥冉坤 发表于 2020-3-20 13:56
没有 但是我想可以用SimpleBLEPripheral和lightblue来调

额...现在状况是用lightblue模拟成SimpleBLEPripheral外设我也是行不通,最后显示结果还是write error。这种情况是怎么回事?个人觉得是CC2540的问题,应该要怎么解决比较好?希望得到解答,谢谢
2020-3-20 09:57:46 评论

举报

上海鼎廷 发表于 2020-3-20 14:05
额...现在状况是用lightblue模拟成SimpleBLEPripheral外设我也是行不通,最后显示结果还是write error。这种情况是怎么回事?个人觉得是CC2540的问题,应该要怎么解决比较好?希望得到解答,谢谢

那首先尝试用2540和2540通讯 一个跑central 一个跑prepheral 这样好调一些 撇开可能手机侧的问题
2020-3-20 10:05:10 评论

举报

合肥冉坤 发表于 2020-3-20 14:13
那首先尝试用2540和2540通讯 一个跑central 一个跑prepheral 这样好调一些 撇开可能手机侧的问题

2540和2540通讯没问题,2540从机和iOS设备通讯有问题,只有2540主机和iOS设备通讯有问题,这时候我lightblue模拟iOS设备和2540主机连接也有问题。所以我想询问下2540这时候有没什么参数需要设置?
2020-3-20 10:16:33 评论

举报

打错了,2540从机和iOS设备通讯是没问题的
2020-3-20 10:33:19 评论

举报

上海鼎廷 发表于 2020-3-20 14:41
打错了,2540从机和iOS设备通讯是没问题的

iOS有个连接参数的要求 你可以尝试根据这个规则修改一下链接参数 但是我现在是手机上网 查不到链接参数的要求 您得上网查一下
2020-3-20 10:40:12 评论

举报

合肥冉坤 发表于 2020-3-20 14:48
iOS有个连接参数的要求 你可以尝试根据这个规则修改一下链接参数 但是我现在是手机上网 查不到链接参数的要求 您得上网查一下

0.0那方便的话可否发一份连接参数的要求资料给我?在论坛里面只找到一些,但我怕不完整~THX
2020-3-20 10:45:37 评论

举报

只有小组成员才能发言,加入小组>>

1225个成员聚集在这个小组

加入小组

创建小组步骤

关闭

站长推荐 上一条 /7 下一条

快速回复 返回顶部 返回列表