发 帖  
[问答] 单片机串口收发字符串出现乱码,请问是什么原因导致的?如何解决?
2018-7-9 14:10:50  308 单片机串口 字符串
收藏 0 收藏 推荐 0 推荐
分享
大家有空帮我看下我这为什么只能接收一个字符 而接收字符串 串口就会出现乱码问题, QQ图片2018.png

一下是我的代码
#include "N76E003.h"
#include "SFR_Macro.h"
#include "Common.h"
#include "Delay.h"
#include "Function_define.h"
#include "string.h"
#include "intrins.h"


#define BUFFER_SIZE                16
#define   N     2


char  UART_BUFFER[BUFFER_SIZE],temp,i;
UINT16 u16CNT=0,u16CNT1=0;
bit riflag;


/**
* FUNCTION_PURPOSE: serial interrupt, echo received data.
* FUNCTION_INPUTS: P0.7(RXD) serial input
* FUNCTION_OUTPUTS: P0.6(TXD) serial output
*/
void SerialPort0_ISR(void) interrupt 4
{
        if(RI)
        {
                RI = 0;
                UART_BUFFER[u16CNT++] = SBUF;
                if(u16CNT==N)
                {
                        riflag = 1;
                }
        }
}


/************************************************************************************************************
*    Main function
************************************************************************************************************/
void main (void)
{
                P12_PushPull_Mode;
                P06_Quasi_Mode;
                P07_Quasi_Mode;
        
                SCON = 0xD0;                        // Special setting the mode 3 and
                TMOD |= 0x20;            //Timer1 Mode1
   
                set_SMOD;                //UART0 Double Rate Enable
                set_T1M;
               clr_BRCK;                //Serial port 0 baud rate clock source = Timer1
                TH1 = 256 - (1000000/115200+1);               /*16 MHz */
                set_TR1;
        
                set_RB8;                                        //This bit is for setting the stop bit 2 high/low status,
        
                clr_TI;
                 set_ES;           //enable UART interrupt
                set_EA;           //enable global interrupt


               while(1)
                {
                        if(riflag==1)
                        {
                                ES = 0;
                                for(temp=0;temp<N;temp++)
                                {
                                        SBUF=UART_BUFFER[temp];
                                         while(!TI);
                                        TI=0;
                                }
                                temp=0;
                                ES = 1;
                                riflag = 0;
                        }
                }
}


帮指点一下,谢谢

2018-7-9 14:10:50   评论 邀请回答
1个回答
找到问题了,我把波特率改为9600就行了  
2018-7-9 14:47:32 评论

举报

撰写答案

你正在撰写答案

如果你是对答案或其他答案精选点评或询问,请使用“评论”功能。

高级模式
您需要登录后才可以回帖 登录 | 注册

提问题
关闭

站长推荐 上一条 /9 下一条

快速回复 返回顶部 返回列表