发帖 |
[问答] 驱动小喇叭对电源造成了影响怎么解决
2018-5-17 10:51:55  770 单片机 三极管
收藏 1 收藏 推荐 0 推荐
分享
用单片机输出PWM控制S8050三极管的开关,来控制喇叭的通断,喇叭阻抗为16欧姆,功率为0.5W,接通时电流约为150MA,驱动电路如下,画的有点丑。。。实测喇叭可以工作,但是对显示屏(12V)造成了影响,屏幕画面会闪烁。测量电压,在喇叭响时,12V电压电压会下降3V左右,怎样解决这个问题呢,求解。。。

驱动电路

驱动电路
2018-5-17 10:51:55   评论 邀请回答
18个回答
三极管上面电阻改成6欧姆了。。。。忘记说了
2018-5-17 11:53:43 评论

举报

楼主的电源容量够大吗?
2018-5-17 12:54:53 评论

举报

王栋春 发表于 2018-5-17 12:54
楼主的电源容量够大吗?

开关电源啊,没问题的
2018-5-17 13:09:40 评论

举报

liuzhiying 发表于 2018-5-17 13:09
开关电源啊,没问题的

我指的是开关电源的输出电流是否能满足需要
2018-5-17 13:42:33 评论

举报

楼主12V电源的提供的输入功率有多大?或者输入电流有多大?
2018-5-17 13:48:12 评论

举报

王栋春 发表于 2018-5-17 13:42
我指的是开关电源的输出电流是否能满足需要

满足,现在基本找到原因,但是不知道怎么解决。把喇叭的供电接在电源上,不经过屏幕就没问题,考虑是三极管开关瞬间电流过大(150ma)引起的,还没找到解决办法。。
2018-5-17 14:52:34 评论

举报

八分之一 发表于 2018-5-17 13:48
楼主12V电源的提供的输入功率有多大?或者输入电流有多大?

12V  2A完全够用了
2018-5-17 14:53:02 评论

举报

liuzhiying 发表于 2018-5-17 14:52
满足,现在基本找到原因,但是不知道怎么解决。把喇叭的供电接在电源上,不经过屏幕就没问题,考虑是三极管开关瞬间电流过大(150ma)引起的,还没找到解决办法。。

将喇叭挪一下位置看看
2018-5-17 19:21:41 评论

举报

单片机是5V还是3.3V的?如果是5V的,建议在三极管基极串联一个小电阻
2018-5-18 09:04:06 评论

举报

王栋春 发表于 2018-5-17 19:21
将喇叭挪一下位置看看

不行的,还是电流大的原因
2018-5-22 09:12:16 评论

举报

勇哥-lzu 发表于 2018-5-18 09:04
单片机是5V还是3.3V的?如果是5V的,建议在三极管基极串联一个小电阻

跟基极关系不大吧,主要是导通时瞬间电流太大
2018-5-22 09:13:12 评论

举报

liuzhiying 发表于 2018-5-22 09:13
跟基极关系不大吧,主要是导通时瞬间电流太大

电源可以输出2A的电路,瞬间150mA的电流不会造成太大压降的
2018-5-22 15:00:56 评论

举报

liuzhiying 发表于 2018-5-22 09:13
跟基极关系不大吧,主要是导通时瞬间电流太大

电源可以输出2A的电路,瞬间150mA的电流不会造成太大压降的
2018-5-22 15:01:16 评论

举报

2018-6-6 09:17:01 评论

举报

"把喇叭的供电接在电源上,不经过屏幕就没问题",怎么共用电源的??
2018-6-6 19:02:38 评论

举报

在12v电源上并联个大电解电容
2018-6-28 10:03:10 评论

举报

AMS1117-3.3V电源驱动小了点,把AMS1117-3.3V换成SPX1117-5V 800mA
2018-7-4 09:07:33 评论

举报

你把117-3.3去掉,上拉的从12V分进去试试
2018-7-5 14:44:39 评论

举报

撰写答案

你正在撰写答案

如果你是对答案或其他答案精选点评或询问,请使用“评论”功能。

高级模式
您需要登录后才可以回帖 登录 | 注册

提问题
关闭

站长推荐 上一条 /9 下一条

快速回复 返回顶部 返回列表