[问答] 如何解决交流伺服电机运转时对传感器的信号干扰问题

[复制链接]

实习生

发表于 2017-10-5 17:38:59   1041 查看 5 回复 显示全部楼层 倒序浏览
分享
如题,

在使用气压传感器测量由交流伺服电机驱动的模型表面风压时,得到的风压受到电机的严重干扰。将伺服电机断电后,传感器工作正常。由于不是专业人员,经过许多尝试,都没能解决这个问题,特向论坛里的各位前辈大神请教解决方案。

问题的具体描述如下,

伺服电机的和压力传感器的布置如下图所示,



在风速为0时(传感器只能测到均值为0的白噪声信号),正常的和受到干扰的风压信号时程和频谱特性如下图所示,




因为不是从事电子方面的工作,对此也一头雾水。根据搜罗的一些建议,进行了如下一下尝试
1. 将交流伺服电机和侧压力传感器电压分别接在两个隔离电源上,干扰仍然存在,没有减弱;
2. 将压力传感器用铁盒包裹,干扰仍然存在,干扰的强度有所减弱;
3. 将压力传感器远离伺服电机,干扰仍然存在,干扰强度有轻微减弱。
附件: 您需要 登录 才可以下载或查看,没有帐号?注册
奖励1积分
标签:EMC整改 电机干扰

实习生

发表于 2017-10-5 17:43:33    楼主|
帮顶,求各路大神指点
回复

点赞 举报

实习生

发表于 2017-10-5 17:43:35    楼主|
帮顶,求各路大神指点
回复

点赞 举报

实习生

发表于 2017-10-8 00:29:36    楼主|
请问各位大神,这个做EMC测试能解决问题吗
回复

点赞 举报

高级工程师

发表于 2017-10-31 23:45:58  
传感器引线使用屏蔽线并接地,电源加装滤波器。
回复

点赞 举报

技术员

发表于 2017-11-1 08:49:19  
伺服电机驱动线加屏蔽并双端接地,另一种是伺服电机驱动器输出处加锰锌磁环绕3-6圈。
回复

点赞 举报

高级模式
您需要登录后才可以回帖 登录 | 注册

关闭

站长推荐 上一条 /8 下一条

快速回复 返回顶部 返回列表
-

推荐专区

技术干货集中营

专家问答

用户帮助┃咨询与建议┃版主议事

工程师杂谈

工程师创意

工程师职场

论坛电子赛事

社区活动专版

发烧友活动

-

嵌入式论坛

ARM技术论坛

Android论坛

Linux论坛

单片机/MCU论坛

FPGA|CPLD|ASIC论坛

DSP论坛

嵌入式系统论坛

-

电源技术论坛

电源技术论坛

无线充电技术

-

硬件设计论坛

PCB设计论坛

电路设计论坛

电子元器件论坛

控制|传感

总线技术|接口技术

-

测试测量论坛

LabVIEW论坛

Matlab论坛

测试测量技术专区

仪器仪表技术专区

-

EDA设计论坛

multisim论坛

PADS技术论坛

Protel|AD|DXP论坛

Allegro论坛

proteus论坛|仿真论坛

EasyEDA-中国人自已的EDA工具

Orcad论坛

-

综合技术与应用

电机控制

智能电网

光电及显示

参考设计中心

汽车电子技术论坛

医疗电子论坛

-

开源硬件

-

无线通信论坛

无线通信技术专区

天线|RF射频|微波|雷达技术

-

IC设计论坛

芯片测试与失效分析

Mixed Signal/SOC[数模混合芯片设计]

Analog/RF IC设计

设计与制造封装测试

-

厂商专区

TI论坛

TI Deyisupport社区

-

检测技术与质量

电磁兼容(EMC)设计与整改

安规知识论坛

检测与认证

-

消费电子论坛

手机技术论坛

平板电脑/mid论坛

音视/视频/机顶盒论坛

-

电子论坛综合区

聚丰众筹官方社区

新人报道区

聚丰供应链

-

论坛服务区

-

供求信息发布

供需广告

招聘┃求职发布区

电子展览展会专区